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FILE DI CALIBRAZIONE   (Cartelle separate per ogni tipologia di scatto) 

 

BIAS 

Servono per correggere il rumore di lettura del sensore della camera, ovvero il rumore che si genera quando questo si attiva 
per leggere i valori di carica dei fotoresistori. 

 

DARK 

I dark frames correggono il rumore termico che il sensore sviluppa mentre è attivo e converte il segnale luminoso (fotoni) in 
carica elettrica. 

 

FLAT  

I flat mappano la differenza di sensibilità alla luce dei vari pixel che compongono il sensore. Sono in grado di eliminare tutte 
le variazioni luminose introdotte dall’ottica, come la caduta di luce periferica, la vignettatura. 

 

DARKFLAT 

I darkflat servono per calibrare i flat frame perché questi contengono sia il rumore di lettura che la modesta quantità di dark 
current che si accumula sul sensore in quel breve lasso di tempo. 

 

LE IMMAGINI DELL'OGGETTO CHIAMATE COMUNEMENTE LIGHT 

I light vanno raggruppati per tempo di scatto e sensibilità; nel caso delle camere astronomiche anche per binning e se 
ottenuti a camera raffreddata, anche per temperatura. Devono essere un minimo di 3 per essere integrati da Pixinsight. 

 

ELABORAZIONE IN PIXINSIGHT 

Di seguito viene riportato il processo di elaborazione che eseguo in PIXINSIGHT. Questo processo di elaborazione avviene 
mediante esecuzione / applicazione di process e di script. 

L’uso di un process durante la fase di lavoro prevede che prima di usarlo gli si impostano i parametri. 

I process generalmente si eseguono trascinando il triangolo blu presente in basso a sx delle loro finestre, sull’immagine da 
elaborare.  

Il collegamento al process, può essere salvato con i parametri preimpostati: si trascina il loro triangolo blu sulla finestra di 
lavoro → si crea un’icona avente una “N” in alto a destra. Cliccando questa “N” è possibile dare un nome al collegamento, 
questo deve essere il nome più opportuno per identificarne l’uso.  

Le icone di collegamento ai process possono essere poste sullo spazio di lavoro con un ordine sequenziale di applicazione.  

Salvando poi il progetto di lavoro: “Save Project” e dandogli un nome comprensibile, es. Project_Base, queste icone di 
collegamento saranno poi disponibili ogni volta che si apre quel Project, sarà un aiuto per le elaborazioni successive. 

Avendo quindi salvato i project di elaborazione con le icone di process sullo spazio di lavoro, molti process (con i parametri 
quindi già impostati), potranno essere direttamente applicati trascinando la loro icona direttamente sull’immagine da 
elaborare.  

Nel testo ho evidenziato in giallo le parti che voglio tenere in evidenza, oppure perché si tratta di testo appena inserito 
rispetto alla versione precedente. 

Ho scritto in “blu – normale” gli eventuali riferimenti a siti internet 

Ho scritto in “blu – corsivo” le parti di testo indicanti processi alternativi o spiegazioni 

Accanto ad ogni fase, una “A” indica quei process che potranno essere applicati trascinando semplicemente la loro icona 
direttamente sull’immagine da elaborare, in quanto i parametri son rimasti memorizzati. Con “F” ho invece evidenziato quei 
process o script da “fare”, cioè dove i parametri sono da inserire perché non memorizzabili. 

 

IL MIO PROJECT BASE – Fasi di lavoro 

 

1) IL SUBFRAME SELECTOR, si apre in tre finestre  

Serve per scartare quelle immagini con difetti, una scrematura dei file 

Il processo si trova nel menu Process > Preprocessing > Subframeselector 

L’icona salvata mantiene i parametri precedentemente impostati 
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Prima routine deve essere: Measure Subframe 

Dal pulsante Add Files, carichiamo i file lights da analizzare 

System Parameters 

- Subframe Scale x.xxxx arcoseconds/pixel   

si ricava caricando una delle light su sito Astrometry.net – Upload (https://nova.astrometry.net/upload). È un valore 
specifico per ogni setup composto da telescopio e camera (es.: 1,4 arcsec/pixel per mia ASI 294 su GSO 154/600 con 
guida 32/130; adesso con guida 64/120 vale 1,57) 

- Camera gain → 1.0375 electrons/data numbers per ASI 294 
- Camera resolution → 14 bit per ASI 294 
- Data unit → Electrons (e-) 

Output Files 

- Directory → la cartella di destinazione (es. PES – file pesati) da aggiornare ogni volta 
- Prefix non serve  
- PostFix → _a 
- Keiword → SSWEIGHT  
- On error → Continue 

Caricati i file light e compilati tutti i campi si lancia il processo di misurazione tramite il pallino blu  

Terminato il processo esaminiamo la seconda finestra: Subframe Selector Measurements 

Compaiono i light analizzati, ordinati secondo il criterio selezionato in “Measurements Graph” 

• Di solito come riferimento si prende il PSF Flux , ma i principali valori da considerare sono la FWHM che 
rappresenta la grandezza delle stelle, la Eccentricity che esprime il valore di rotondità delle stelle e la SNR  
Weight dove il valore di segnale nelle nostre immagini che deve essere il più alto possibile.  

Con una croce sono indicati i lights che verranno scartati dal processo secondo la Subframe Selector Expression. 
L'espressione che il processo utilizzerà come criterio di selezione può essere:  

Approval → Weight>70 (accettati tutti i lighs che superano il 70% della Weighting) 

Weighting →  La formula standard da scrivere è: 

(20*(1-(FWHM-FWHMMin)/(FWHMMax-FWHMMin)))+(20*(1-(Eccentricity-EccentricityMin)/(EccentricityMax-
EccentricityMin)))+(20*(PSFFlux-PSFFluxMin)/(PSFFluxMax-PSFFluxMin))+50 

 

• Per lavorare una nebulosa: 

(10*(1-(FWHM-FWHMMin)/(FWHMMax-FWHMMin)))+(10*(1-(Eccentricity-EccentricityMin)/(EccentricityMax-
EccentricityMin)))+(30*(SNRWeight-SNRWeightMin)/(SNRWeightMax-SNRWeightMin))+50 

Valori considerati in automatico sono: 

FWHMMin = 3.835   FWHMMax = 6.981 

EccentricityMin = 0.5527 EccentricityMax = 0.8920 

SNRweightMin = 1.371  SNRweightMax = 1.544 

 

• Per lavorare una galassia: 

(15*(1-(FWHM-FWHMMin)/(FWHMMax-FWHMMin)))+(15*(1-(Eccentricity-EccentricityMin)/(EccentricityMax-
EccentricityMin)))+(20*(SNRWeight-SNRWeightMin)/(SNRWeightMax-SNRWeightMin))+50 

 

• Per un ammasso, l'espressione migliore sarà: 

(20*(1-(FWHM-FWHMMin)/(FWHMMax-FWHMMin)))+(20*(1-(Eccentricity-EccentricityMin)/ (EccentricityMax-
EccentricityMin)))+(10*(SNRWeight-SNRWeightMin)/(SNRWeightMax-SNRWeightMin))+50 

 

Seconda routine: passare da “Measure Subframes” (finestra 1) in “Output Subframes”  

Non variare parametri, ma eseguire il process tramite pallino blu nella barra in basso a sinistra 

I file verranno salvati (quelli scremati) nella cartella di destinazione scelta (es. PES). 

 

2) IL WEIGHTED BATCH PREPROCESSING 

Si trova nel menu script > Batch Processing > Weighted Batch Preprocessing Script. 

L’icona salvata mantiene i parametri precedentemente impostati, cancellare quindi i frame da ogni label 

https://nova.astrometry.net/upload
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2a) INTEGRAZIONE LIGHTS RIPRESI IN DATE DIVERSE usando il WBPP (Weighted Batch Pre Processing) 

Se i differenti lights sono compatibili (stesso Flat) è sufficiente:  

• Grouping Keywords → Spuntare la voce 

• Indicare un reference frame nel campo libero sottostante 

• Inserirlo nelle “Keyword col tasto verde “+” → tutte le immagini verranno allineate a esso.  

 

Volendo invece integrare lights ripresi in date diverse e con differente bias, occorre: 

• Creare una cartella es. IC434_Integrated → In essa vanno creare tante cartelle quante sono le date di ripresa.  
o Nominare queste cartelle “DATE xxyyzz”dove xxyyzz sono le date di ripresa, es. “DATE 240114” 

• Copiare in ciascuna cartella “DATE xxyyzz” le cartelle dei PES, dei Flat, dei Dark e dei Darkflat 

 

2b) IL PROCESSO DI WBPP 

Questo script è composto di 7 labels di cui l’ultima “Pipeline” riporta semplicemente l’elenco delle operazioni svolte. 

 

Prima LABEL - Caricare i frames BIAS 

I parametri sono: 

Combination → Average  

Rejection algorithm → Auto, oppure Winsorized Sigma Clipping 

 

Seconda LABEL - Caricare i frames DARKS, anche di diverse durate e anche i DARK FLATS  

I parametri sono: 

Combination → Average 

Rejection algorithm → Auto oppure Winsorized Sigma Clipping 

Si può tuttavia agire sulla tolleranza del tempo di scatto  

Exposure tolerance → Per ottimizzare l'integrazione dei dark con diverso tempo di esposizione e non farli scartare, indicare 
un valore superiore alla differenza tra il valore maggiore e quello minore  

 

Terza LABEL - Caricare i frames FLATS 

I parametri sono: 

Combination → Average  

Rejection algorithm → Auto oppure Winsorized Sigma Clipping 

 

Quarta LABEL - Caricare i frames LIGHT prelevandoli dalla cartella di destinazione scelta prima (es. PES). 

Lo script permette di lavorare con gruppo di file con caratteristiche omogenee e, se necessario, anche di lavorare con gruppi 
di file differenti tra loro sia per durata di esposizione che, nel caso di utilizzo di filtri o di date diverse, tramite uso di parole 
chiave. In ogni caso è anche sempre possibile ottenere un’unica integrazione, un unico master light agendo sulla Calibration 
Exposure Tollerance  

• Calibration Exposure Tollerance → Lasciando un valore basso, es. 2, lo script realizza diversi master light: 
immagini calibrate in base al tempo di esposizione dei frames.  Utile per effettuare un successivo HDR. 

o Per avere un’unica integrazione dei lights con diverso tempo di esposizione, occorre invece indicare 
un valore superiore alla differenza tra il tempo maggiore di esposizione e quello minore.  

• Linear Defect Correction → lasciarla senza spunta. 

• Subframe Weighting → va flaggata e scelta la Weighting Formula dalla tendina,  
o finestra di “Weighting Formula Parameters” → indicare nel Preset il tipo di soggetto  

• Image Registration → va flaggata 
o Registration parameters → lasciare in automatico, flaggare la Distortion Correction 

• Astrometric Solution → lasciare flaggata, flaggare la Interactive in case of failure 

• Local Normalization → lasciare flaggata, la local normalization è fondamentale soprattutto per i gradienti va 
fatta assolutamente sempre 

• Image Integration → va flaggata 
o Autocrop → va flaggato per far fare il ritaglio in automatico, ma solo se si lavora con una sola 

immagine finale. Invece se si deve combinare per esempio immagini con 2 diversi filtri non va usata 
altrimenti non si riesce poi a combinarle tra loro 
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o Integration parameters: Combination → Average e Rejection algorithm → Auto 

• Grouping Keyword (parte destra della finestra di process) → va flaggata quando si lavorano gruppi di 
immagini con caratteristiche diverse 

o Nel caso di gruppi con diversa data di ripresa, per fare integrazione tra loro, indicare nel campo 
Keyword la parola “DATE” (che distingue le directory dello stesso soggetto, ma prodotte in tempi 
diversi ) e renderla operativa mediante icona “+” di colore verde 

 

Quinta LABEL - CALIBRATION - si trova un riassunto schematico di ciò che farà lo script.  

Cliccando su ogni voce si attivano in verde i file coinvolti nella calibrazione della voce stessa.  

Nella label Calibration, cliccando sulla voce Lights, a destra si attivano delle voci: 

Calibration Setting:  

• Dark → Auto 

• Flat → Auto;  

• Optimize Master Dark → flaggare solo se non si ha a disposizione il dark corretto come esposizione  

 

Cosmetic Correction: 

• Automatic → Togliere la spunta 

 

CFA settings, riguarda il debayer della nostra immagine: 

• CFA images → deve essere flaggata solo se l'immagine è a colori 

• Mosaic pattern → Normalmente in Auto dovrebbe riconoscere la matrice di Bayer della camera 

• Debayer method → VNG 

Il pulsante Show Calibration Diagram mostra graficamente come avvengono i passaggi di calibrazione. 

 

Cliccando invece sulla voce Flats della label Calibration, a destra si attivano delle voci:  

CFA Setting: 

• CFA images → deve essere flaggata se l'immagine è a colori 

• Separate CFA flat scaling factors → deve essere flaggata, comporta la separazione dei tre canali colore e la 
calibrazione dei flat con i singoli canali separatamente, è utile nei casi in cui i nostri flat siano stati presi con una 
luce non del tutto neutra e corretta.  

Il pulsante Show Calibration Diagram mostra graficamente come avvengono i passaggi di calibrazione. 

 

Registration Reference Image: 

Mode → auto se abbiamo un unico set di immagini fatte con unico filtro o senza, unico soggetto → Lo script identifica in 
automatico il frame da usare come riferimento durante l'allineamento dei light, se lasciato in Auto lo script analizza per noi 
le immagini scegliendo quella che avrà la migliore FWHM cioè il valore più basso e la più alta SNR 

Mode → Manual se abbiamo 2 o più set di immagini fatte cioè con filtri diversi, tempi diversi, ecc. che devono essere 
registrati su un’unica immagine di riferimento. Da uno dei set, analizzati con il processo Subframe Selector occorre poi 
indicare un frame che sarà preso da riferimento. 

 

Sesta LABEL - POST-CALIBRATION – Mostra il risultato di ciò che otterremo a processo avvenuto, il numero di light, il tempo 
di esposizione, il tempo totale di integrazione dovuto dalla somma di tutti i subframe light.  

A destra si attivano delle voci 

• Exposure tolerance → indicare un valore adeguato al risultato che si vuole ottenere 
o con un valore basso (es “2”), se abbiamo un gruppo omogeneo di frames o se abbiamo lavorato frames 

con esposizioni di durata diversa o con filtri diversi, avremo gruppi di file per ciascun tempo o nel caso di 
filtri, separati per ciascun filtro 

o un valore elevato (es “200”), consente di unificare sotto un unico gruppo anche gruppi di light diversi tra 
loro per tempo di esposizione o per filtro impiegato. 

• Channels configuration → possiamo anche scegliere se ottenere un master light RGB combinato oppure i singoli 
canali, oppure entrambi 

o Sotto appaiono i passi attivi nel processo, quindi la calibrazione, l'allineamento e la somma 
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• Drizzle configuration → Spuntare la casella se vogliamo che vengano generati i file drizzle. Serve solo se dobbiamo 
lavorare dei file che sono fortemente sotto-campionati. In questo caso andrà a correggere questo sotto-
campionamento aumentando la dimensione dei pixel. 

• Grouping Keywords → Consente, tramite delle parole chiave inserite a monte nella denominazione dei file, di 
lavorare facilmente con dei filtri per gruppi di file identificati da queste parole chiave.  

• Output Directory → Indicare una cartella di destinazione dei nostri file lavorati (es. PIX) dove, a fine processo, 
trovare salvati i vari master, i file debayerizzati, i file allineati ed eventualmente i file drizzle.  

A questo punto premere il pulsante Diagnostic → Mostra se tutto ciò che abbiamo caricato e le impostazioni messe sono 
corrette o se non ci sono dei problemi. Se la diagnosi dà l'ok allora lanciamo il RUN. 

Run → Il processo parte e possiamo vedere scorrere velocemente il flusso di lavoro sulla Process Console a sinistra. A fine 
processo si aprirà un report che indica ciò che è avvenuto, se tutto è andato bene o se ci sono stati problemi o errori.  

Ci indicherà anche il numero di file utilizzati, scartati, allineati e registrati. 

Chiuso il WBPP possiamo aprire il file master light dalla cartella MASTER di salvataggio e iniziare l’elaborazione. 

Se il WBPP non funziona, Process → ImageIntegration  poi Script → ImageAnalisys → Image Solver 

 

TRATTAMENTO ESTETICO DELL’IMMAGINE 

Tutto quanto avviene applicando script o processi è visibile nella Process Console che si apre sul lato sinistro della finestra di 
lavoro. 

 

3) ELABORAZIONE IN FASE LINEARE  

Dalla cartella MASTER aprire l'immagine master light RGB_autocrop. L’immagine da lavorare ora risulta nera, si vedono solo 
le stelle in quanto è ancora in fase lineare. 

Chiudere le immagini di rigetto che si aprono contemporaneamente 

Aprire il process STF (Screen Transfer Function) Autostretch che simula come potrà essere l’immagine stretchata. 

Il processo si trova nel menu Process > Intensity Transformations > Screen Transfer Function 

L’icona salvata mantiene i parametri precedentemente impostati 

• Cliccare sul simbolo della catena → viene slacciata la regolazione unita dei canali RGB (altrimenti colori errati).  

• Cliccare su Autostretch (simbolo radioattivo) → i colori ora sono migliori, più reali 

• Se resettiamo, l’immagine torna come era prima 

 

4) EQUALIZZARE LA LUMINANZA 

Aprire il process RGB Working Space. Serve ad equalizzare la luminanza dei tre canali RGB, utile quando estrarremo la 
luminanza della nostra foto.  

Il processo si trova nel menu Process > Color Spaces > RGB Working Space 

Impostare a 1 i valori di luminanza di tutti e tre canali. Serve per aumentare ed equalizzare la luminanza dell’immagine.  

Applicare il process trascinando il triangolo blu sul campo dell'immagine. 

 

Per equalizzare la luminanza, in alternativa si sarebbe dovuto applicare lo Split RGB Channels (icona accanto a quella della 
Luminanza) che avrebbe diviso l’immagine nei 3 canali stretchabili Rosso, Blu e Verde. 

Poi si sarebbe dovuto aprire il process LinearFit in cui indicare il canale verde come immagine di riferimento e poi tirare il 
triangolo blu del process sulle immagini dei canali Rosso e Blu.  

Per finire, tramite il process Channel Combination, lavorando in ColorSpace RGB si ricombinano tra loro i tre singoli canali 
che andremmo rispettivamente a richiamare tramite le icone laterali. Pulsante rotondo di Apply. Chiudere i process e i 3 
canali equalizzati e dare un nome all’immagine ottenuta.  

Il linear fit è però sostituito (e quindi non più necessario) da quando esiste la calibrazione del colore spettro fotometrica , che 
già provvede a mettere a posto i canali tra di loro, quindi tutto questo metodo è stato semplificato 

 

Bilanciamento cromatico 

Prima di eliminare i gradienti bisognerebbe provvedere al bilanciamento cromatico. Si dovrebbe utilizzare il process 
Background Neutralization, dandogli come riferimento un’anteprima, ovvero una porzione di immagine di cielo nero privo di 
nebulosità o stelle. Esplorando la porzione del mouse trovare il valore più alto leggibile nella riga in basso di Pixinsight, in 
riferimento ai 3 canali RGB. Indicare per eccesso questo valore nell’Upper limit ed applicare il process tirando il triangolo 
sull’immagine. Dopo ogni tool applicato, occorre rifare l’STF Autostretch perché la nostra anteprima non si aggiorna da sola. 
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5) ELIMINAZIONE DEI GRADIENTI   

Aprire il process ABE Gradienti. Serve ad uniformare il profondo cielo eliminando tutti i vari gradienti ed aiuta anche ad 
eliminare i gradienti da illuminazioni esterne. 

Nota: Questo Process non si esegue più, sostituito da GraXpert o Gradient Correction.   

 In verità però l'abe si può ancora utilizzare e si rivela utile quando non è possibile croppare l'immagine perché si sta 
lavorando con immagini da combinare tra loro come per l'utilizzo di piu filtri, in questi casi il gradient correction o il 
graxpert non funzionano bene se l'immagine ha dei difetti sui margini che non si possono croppare 

Il processo si trova nel menu Process > Background Modellization > Automatic Background Extractor 

L’icona salvata mantiene i parametri precedentemente impostati 

Nella sezione Interpolation e Output i parametri da impostare sono: 

• Function Degree → la impostiamo al minimo cioè 1,  

Nella sezione Target Image Correction: 

• Correction → scegliamo Subtraction nel momento in cui abbiamo gradienti di inquinamento 
o scegliamo Division solamente se abbiamo solo qualche sbilanciamento, o magari l’assenza dei Flat o 

qualche parte più scura ma non veri e propri gradienti di inquinamento 

• Flagghiamo la voce Normalize e anche la Replace Targhet Image. 

Applichiamo il process con il solito triangolo trascinato sull’immagine.  

Con il tasto destro del mouse sulla foto, scegliamo Identifier, quindi anteponiamo ABE al nome del file. 

Il programma non consente spazi vuoti nel nome →mettere il simbolo “_” tra una parola e l’altra. 

Salvare l’immagine da File > Save As > ABE_nomefile 

 

6) GRADIENT CORRECTION 

Aprire il process Gradient Correction 

Il processo si trova nel menu Process > GradientCorrection > GradientCorrection 

Non serve modificare parametri → Triangolo blu sull’immagine da elaborare 

 

7) PRIMA RIDUZIONE DEL RUMORE      

Tasto destro del mouse sulla foto, scegliamo Identifier → Rinominiamo il file in “B” 

Tasto destro del mouse sulla foto, scegliamo Duplicate → Duplichiamo l'immagine > in automatico si nominerà “Clone”  

o si può anche fare agganciando l'etichetta della foto e trascinandola di lato 

Tasto destro del mouse sulla foto “Clone”, scegliamo Identifier → Rinominiamo il file in “R” che sta per rumore 

Ora lavoriamo sull'immagine R lasciamo temporaneamente da parte la nostra immagine principale B 

 

 7a)  Apriamo il process Atrous Wavelet Transform    

Il processo si trova nel menu Process > Compatibility > Atrous Wavelet Transform 

L’icona salvata mantiene i parametri precedentemente impostati 

• Lasciamo attivo (con la spunta verde) solo il primo Layer mentre con doppio click sulla spunta verde disattiviamo gli 
altri che ora prendono la X rossa  

• Lasciamo gli altri parametri di default, senza attivare il Noise Reduction 

• Applichiamo il process con il solito triangolo che portiamo sulla foto R →  vedremo che diventa nera 

• Applichiamo la STF noteremo come si veda solo grana di rumore, che è quella che vogliamo eliminare.  

 

7b) SOTTRAZIONE DEL RUMORE   

Apriamo il process Pixel Math 

Il processo si trova nel menu Process > PixelMath > PixelMath 

Expressions → scriviamo l'espressione “nome della nostra foto principale – rumore“: es. B-R,  

Destination → lasciamo Replace Target Image  

Applichiamo il process alla foto principale B portandovi sopra il triangolo blu. 

Chiudiamo l’immagine R, non ci servirà più 
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8) ESTRAZIONE DELLO SFONDO  Non si esegue più, sostituito da GraXpert, ma resta come alternativa 

Apriamo il process Dynamic Background Extraction per estrarre e regolarizzare lo sfondo della nostra immagine  

Si trova in Process > Background Modelization > Dynamic Background Extraction 

Sull’immagine compare una croce che divide la foto in quattro quadranti → Con la crocetta del mouse andare a cliccare nelle 
zone di profondo cielo prive di nebulosità, rilasciando dei marcatori almeno 5 in ciascun quadrante sia nelle zone periferiche, 
ma anche per tutta l’immagine in modo da creare un modello completo e rappresentativo della nostra fotografia.  

o quantità maggiori consentono un modello di sfondo il più dettagliato, saranno dei riferimenti per la 
regolarizzazione del fondo cielo e l'eliminazione di dominanti di colore. 

Nel monitor della finestra del Process si visualizza l'ingrandimento dei singoli sample che posizioniamo.  

Spostiamo eventuali punti campione che presentino molti pixel neri: i pixel chiari sono le zone più scure del cielo nelle quali 
dobbiamo aver selezionato. 

• Nella sezione Model Parameters Tollerance di default è 0.5 → Il valore di Tolerance gestisce la tolleranza, 
aumentandola permette di intervenire su aree più ampie dell’immagine. 

o Qualora non si riuscisse ad avere Sample point verdi (ma restassero rossi), aumentare progressivamente la 
Tolerance (sino massimo a 1) fino a restituire i sample di colore verde. I marcatori che risultano rossi 
indicano che questi non vengono gestiti in questo valore di tolerance 

Il sistema automatico di generazione dei Sample point può produrli in zone non volute perciò vanno comunque 
controllati ed eventualmente spostati o rimossi.  

• Nella sezione Target Image Correction → selezionare la correzione da applicare alla foto.  
o Se non selezioniamo nulla otterremo solo il modello dello sfondo senza nessuna azione sulla foto → 

conviene effettivamente fare il DBE più volte senza selezionare la Target Image Correction al fine di vedere 
tramite l’immagine del background, il miglior risultato, raggiungibile aumentando le crocette 

o Se dobbiamo correggere gradienti di disturbo dobbiamo usare Subtraction,  
o Se invece vogliamo correggere eventuali vignettature dobbiamo scegliere Division.  

Volendo si possono fare i due passaggi, la sottrazione prima e la divisione dopo. 

• Normalize → non serve usarlo perché la normalizzazione verrà fatta da SPCC.  

• Discard Background Model non spuntare: a fine esecuzione mostra la mappa del modello del cielo. 

Applichiamo il process portando il triangolo blu sull’immagine. 

• Viene creata immagine del background → guardare tramite l’STF che abbia scartato solo rumore di sfondo  

La nostra immagine è ora più pulita → Se non applicato dal process, aggiungiamo DBE al nome 

Questo processo può essere applicato quante volte si voglia per migliorare ulteriormente l’immagine, magari aumentando 
ancora un poco la Tolerance se ci sono zone ancora non ben bilanciate. 

 

9) Eventuale IMAGE SOLVER DELL’IMMAGINE 

Aprire lo script Image Solver 

Si trova in Script > Image Analysis > Image Solver 

• Image Parameters → indicare data in cui è stata fatta la ripresa  
o in caso di immagine derivata da raggruppamento di immagini aventi diversa data di ripresa → indicare 

almeno una delle loro date 

• Fare Search → indicare l’Object identifier → Search → dare OK 

• Model Parameters → indicare Local XPSD → Gaia DR3 (XPSD) presente sul nostro computer 

Dare esecuzione allo script mediante tasto “OK” 

 

10) ELIMINAZIONE DEI GRADIENTI con GRAXPERT  Oppure con Gradient correction 

Apriamo il process GraXpert 

Il process si trova in Process > “Etc” > GraXpert  (Come script hanno le stesse caratteristiche e funzioni) 

Il process raggruppa sia il Background Extraction, sia il Denoising, ma sono attivabili una alla volta. 

Background Extraction 

• Smoothing Factor → Correggere eventualmente il valore di controllo dell’intervento di GraXpert. Nella maggior 
parte dei casi il fattore di smoothing factor predefinito pari a 0,0 dovrebbe essere la scelta migliore. 

• Correction → scegliamo Subtraction nel momento in cui abbiamo gradienti di inquinamento 

→ scegliamo Division solamente se abbiamo solo qualche sbilanciamento, o magari l’assenza dei Flat       
o qualche parte più scura ma non veri e propri gradienti di inquinamento 
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• Confermare l’applicazione dello process mediante il triangolo blu in basso a Sx  

Denoising 

• Attiviamo la preview tramite cerchietto blu in basso a Sx  

• Strength → selezionare l'intensità della riduzione del rumore da eseguire tenendo presente che un'eccessiva 
riduzione del rumore potrebbe sembrare innaturale! Valori validi da 0 a 1, di default è 0.5 

• Batch size → Numero di parti di immagine in cui Graxpert andrà a trattare il rumore in parallelo. La dimensione 
batch size è un parametro facoltativo utilizzato solo per migliorare le prestazioni e il valore migliore dipende 
interamente dall'hardware. → predefinito 4 

• Confermare l’applicazione dello process mediante il quadratino blu in basso a Sx → Il risultato è più drastico rispetto 
la preview 

 

11) CALIBRAZIONE DEL COLORE 

Apriamo il process Spectro Photometric Color Calibration per ottenere il colore corretto per i nostri soggetti 

Si trova in Process > Color Calibration > Spectro Photometric Color Calibration. 

I parametri da impostare sono: 

• White reference → Average Spiral Galaxy perché le galassie contengono tutte le bande di emissione e quindi sono 
perfette come riferimento del bianco. 

• QE curve → Ideal QE Curve perché il sensore ASI 294 non è presente nell'elenco 

• Red filter → Sony Color Sensor R  (se non si hanno filtri) 

• Green filter → Color Sensor G 

• Blue filter → Color Sensor B 

• Generate Graph → se flaggata mostrerà i riferimenti del maching delle stelle trovate durante la fase di calibrazione 

• Apply Color Calibration → deve essere flaggata per far sì che la calibrazione venga applicata alla nostra immagine.  

• Catalog → va selezionato il Gaia DR3/SP che è specifico per la spettrofotometria 

• Automatic Limit Magnitude → va flaggata perché il processo possa identificare le stelle visibili 

• Signal Evaluation → lasciare i valori di default 

• Background Neutralization → va flaggata e applicata sulla regione di interesse 

• Region of interest → va flaggata, 
o Creare ora una piccola Preview (icona rettangolo con ombra nel menu Pixinsight) in una zona del profondo 

cielo della nostra foto, un punto non influenzato dalla nebulosa 
o cliccare nel process la voce “From Preview” per fare valutare il fondo-cielo 

• Select Preview → nella tendina scegliere la preview creata e dare l’OK 

Applichiamo il process portando il triangolo blu sull’immagine. 

o Nel grafico restituito le stelle devono essere il più possibile allineate su una retta, diversamente significa 
che qualcosa è andato storto, non ha funzionato → Nel caso, fare Undo sull’immagine e ripetere il 
process, altrimenti chiudere la finestra del grafico 

 

L’immagine risultante risulta nera, allora clicco sull’icona del monitor presente sulla finestra in alto di Pixinsight (questa 
abilita/disabilita l’STF) quindi clicco l’icona STF dal simbolo radioattivo per rivedere i colori stretchati.  

 

12) Eventuale IMAGE SOLVER 

Nell’impossibilità di portare a termine il process SPCC, esempio per immagine croppata, eseguire lo script Image Solver 
come da precedente punto 9  

 

13) RIUNIRE I CANALI COLORE 

Finito il processo i canali sono ancora separati, occorre quindi riunire/reincatenare i canali dei colori: 

• aprire il Process STF sulla foto → cliccare il simbolo della catena  

• Applicare il process cliccando sul simbolo “radioattivo” →i colori vengono portati a come sono effettivamente. 

Volendo posso applicare il process SCNR per eliminare eventuali dominanti verdi ancora presenti 

 

14) OPZIONE HDR per unire immagini 

Se abbiamo più immagini da unire perché magari realizzate con tempi di esposizione diversi, dobbiamo proseguire col 
process HDR Composition. 

Prepariamo prima i file da unire salvandoli in formato XISF 
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Apriamo il process HDR Composition 

Si trova in Process > Image Integration > HDR Composition 

• Aggiungiamo le immagini tramite pulsante Add Files → si apre la directory di ricerca da cui possiamo scegliere 
anche più file assieme 

•  Dobbiamo mantenere in cima della lista le immagini con le esposizioni più lunghe → Modificare l’elenco tramite i 
pulsanti Move Up e Move Down 

• Applichiamo il process tramite pulsante blu rotondo → Vengono prodotte 3 immagini: 
o L’immagine HDR risultante 
o L'immagine HDRMask01 e l'immagine HDRMask02 che sono le maschere che mostrano quali aree 

dell'immagine con esposizione più lunga e più breve sono state sostituite.  

Qui l’elaborazione può proseguire con i preparativi per la Deconvoluzione → vedere i punti seguenti, oppure proseguire con 
riduzioni del rumore e dedicare la Deconvoluzione alla sola nebulosa, saltando cioè al punto 19. 

 

15) DETERMINARE LA CORRETTA PSF  https://www.youtube.com/watch?v=wHOBx8njgD8 

https://jonrista.com/the-astrophotographers-guide/pixinsights/proper-use-of-regularized-richardson-lucy-
deconvolution/ 

Aprire il process Dynamic_PSF 

Si trova in Image → Dynamic_PSF (funzione di diffusione puntuale) 

• Togliere la STF → terzo tasto a dx del monitor 

• PSF Models → Togliere la spunta da “Auto” e altre voci, lasciamo solo la voce “Gaussian”. 

• Selezionare dallo sfondo nero, le stelle appena visibili (una cinquantina almeno), non quelle sature 
o È importante selezionare stelle insature, poiché la saturazione taglia il picco della stella, cambiandone il 

profilo. Pertanto, idealmente si desidera che la maggior parte, se non tutte, le stelle campionate 
nell'immagine abbiano il modello Moffat (colonna “β”). Rimuovi tutte le stelle Moffat10 e gaussiane 

o Occorre scegliere stelle ben isolate, evitando stelle doppie o stelle che hanno stelle vicine. Evitare le stelle 
con aberrazioni ottiche che si verificano solo in una parte dell’immagine, come stelle cromatiche o 
astigmatiche negli angoli, stelle che mostrano problemi di inclinazione, ecc. 

o La cosa migliore è scegliere dalla regione centrale dell’immagine, anche se cercando di rendere quella 
regione il più grande possibile, senza selezionare stelle difettose. 

• Verificare l'errore di adattamento in colonna MAD (deviazione assoluta media) → tutte stelle devono stare nello 
stesso range medio di valore, eventualmente selezionare quelle che non rientrano e toglierle tramite icona “-“ 

o Un adattamento migliore è quello in cui il PSF generato dal computer modella più fedelmente le stelle 
nell'immagine con un errore minimo.  

o Una scarsa corrispondenza tra il PSF e le stelle reali nell'immagine si tradurrà in una scarsa 
deconvoluzione, o molto probabilmente anche in un'ulteriore sfocatura!  

o Minore è l'errore tra la funzione di modellazione e le misurazioni effettive della stella, migliore è 
l'adattamento. 

• Selezionarle tutte con “CTRL+A 

• Digitare l’icona con la macchina foto → viene calcolata la PSF che compare in una piccola immagine che riduciamo 
ad icona 

• Rimettere la STF → tasto col simbolo radioattivo 

 

16) CREARE UNA STAR MASK 

Serve ora una Star Mask per proteggere le stelle e dare supporto alla Deconvolution 

• Creare maschera di luminanza 

• Stretchare con STF con Link RGB → “simbolo 8” applicato → NON chiudere il process STF 

 

Aprire Histogram transformation e scegliere l’immagine di luminanza dal menù a tendina → occorre ora rendere lo 
stretching permanente  

• Avendo STF aperto, trascinare il suo triangolo sulla barra basale dell’Histogram Transformation 

• Applicare Histogram Transformation → trascinare il triangolo blu sull’immagine di luminanza → diventa bianca 

• Rimuovere lo stretching tramite icona di Reset STF active Window (quarto tasto a dx del monitor) 

Chiudere entrambi i process STF e Histogram transformation 

 

 

https://www.youtube.com/watch?v=wHOBx8njgD8
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Aprire il process Star Mask 

• Scale 6 

• Large scale 0 

• Small scale 0 

• Compensation 1 

• Smoothness 12 

• Mettere visto su Binarize → creerà un’immagine binarizzata: o bianco o nero 

• Midtones 0.6 → è una piccola spinta ai mezitoni 

• Applico con triangolo blu sull’immagine della luminanza 

Tenendo col mouse l’immagine Star-Mask che si forma (diventerà trasparente), sovrapporla alla luminanza per vedere che 
abbia preso tutte le stelle volute. 

Chiudere il process Star Mask 

Con Histogram Transformation se è il caso scurire il profondo cielo della Star Mask → Chiudere Histogram Transformation  

Abbassare ad icona la Star Mask creata 

 

17) DECONVOLUTION 

Tre metodi per realizzare la Deconvolution: 

• Parametric PSF → Con Parametric PSF, Pixinsight andrà a calcolare la PSF tramite una funzione gaussiana 

• Motion Blur PSF → Con Motion Blur PSF si riescono a correggere, in alcuni casi, il problema delle stelle allungate.  
o Motion Blur PSF serve per errori di elongazione in una direzione specifica, ma se le stelle sono allungate 

dal centro verso gli angoli Motion blur PSF non serve. 

• External PSF → Con External PSF, Pixinsight andrà ad usare la PSF misurata da noi tramite il process Dynamic_PSF. 

Global Dark, Iterazioni e Local support sono i parametri principali della Deconvolution, ma se il rapporto segnale rumore è 
basso allora la deconvoluzione potrà fare poco e risulterà poco efficiente. 

 

Processo di Deconvolution tramite External PSF 

• Applichiamo la maschera di luminanza all’immagine → vogliamo proteggere la parte di cielo 

• Abbassiamo ad icona la maschera di luminanza 

• Creiamo 1 o più selezioni come aree di preview 

• Aprire Process – Deconvolution – Deconvolution 

• Andiamo nella finestra External PSF 

• View Identifier → Scegliere la PSF creata 

• Algoritmo Regularized Richardson Luchy 

• Iterations 10 (normali valori tra 10 e 30 iterazioni) → aumentando il numero di iterazioni occorrerà aumentare il 
numero di Global Dark perché l’immagine tenderà ad avere più artefatti 

• Deringing → cliccare, serve 

• Global Dark → il valore predefinito di 0,1 è spesso troppo alto. Partiamo da 0.0060. Questo parametro aiuta a 
prevenire gli anelli scuri attorno alle stelle. 

• Global Bright → serve solo nel caso si formino aloni bianchi intorno alle stelle 

• Vistare Local deringing che va a proteggere le stelle nel processo di deconvoluzione 

• Local Support → la Star Mask creata 

• Local amount → modera gli artefatti di deringing, mentre se si riduce questo valore, rende più aggressivo 
l’intervento della PSF anche sulle stelle → 0.70 (70%) è l’ideale 

• Applicare con triangolo blu su una prima preview 

 

Se si formano aloni neri attorno alle stelle → aumentare il valore di Global Dark → es 0.0070 

Se si esagera, compaiono aloni bianchi 

Trovare il giusto compromesso valutando anche su altre anteprime 

CTRL+SHIFT+Z per togliere o applicare la deconvolution 

 

• Wavelet Regularization (Riduzione del rumore)  

• Noise Model → Gaussian 

• Wavelet layers → 2  - B3 Spline 

• Noise Threshold (Soglia di rumore)  Noise reduction (Riduzione del rumore) 

• 1 → 3.00 1.00 
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• 2 → 2.00 0.70 

• 3 → 1.00 0.70 

• 4 → 1.00 0.70 

• 5 → 1.00 0.70 

• Convergence → 0.000 

Normalmente questi valori vanno bene, ma se aumentano in modo significativo il rumore possiamo aumentare le soglie di 
rumore ed i valori di riduzione del rumore tramite prove. 

Trovate le condizioni giuste, applicare sull’immagine 

 

18) RIDUZIONE DEL RUMORE  Oppure Graxpert, oppure ACDNR 

Usiamo lo Script EX –> EZ Denoise → Prima di strechare l’immagine, che adesso è ancora sempre lineare (dopo lo stretch 
sarà più o meno come adesso ma con i colori definitivi), occorre ridurre ulteriormente il rumore. Lo script farà delle 
maschere, utilizzerà il TGV come riduttore di rumore ed il Multiscale Median Transform che sono due diversi processi che 
potremmo trovare anche singolarmente nei Process ma qui li ottimizza e li mette assieme e crea anche le maschere per 
utilizzarli. 

Si trova in Script > EZ Processing Suite > EZ Denoise 

• Nella label Mask Setting, spuntare la voce Close Mask images after Execution 

• Dalla label TGV Setting, flaggando Run TGV Denoise si possono fare delle prove regolando i parametri di Strength:  
o TGV Edge Protection Determination → Edge Protection multiplier → 0,7 è valore normalmente corretto, di 

default 
o Strenght → 2.00000 
o Smoothness sino ad ottenere un’immagine migliore 

• Eseguire Evaluate EZ Denoise Run con 250 Iterations e correggere i valori sino a raggiungere la correzione voluta  

• Riportare a 1650 per l’applicazione definitiva ed avviamo lo script mediante il Run → Il lavoro ci mette un po’ a 
realizzarsi. 

 

19) STRATCHING DELL’IMMAGINE  porta l’immagine da fase lineare a fase NON lineare 

Metodo automatico  oppure con metodo manuale tramite Histogram Transformation 

Apriamo il process HT Stretch Linked RGB HT 

 È uno stretch basato su una espressione di Pixel Math   

• Avviamo il process portando il triangolo blu sull’immagine → l’immagine appare bianca 

• Disabilitare lo Screen Transfert Function → Cliccare l’icona del monitor, riga in alto del menu di Pixinsight 

A questo punto si ottiene l’immagine non più lineare, ma stretchata, definitiva. 

 

20) Secondo GRADIENT CORRECTION 

Ripetere eventualmente il punto 6 per migliorare i dettagli 

 

21) CORREZIONE ISTOGRAMMA 

Dopo aver applicato il processo HT_Stretch_Linked_RGB, qualora la foto risulti troppo chiara, serve usare manualmente 
Histogram Transformation per tagliare un poco i toni scuri. 

Apriamo il process Hystogram Transformation 

Si trova in Process > Intensity Transformation > Hystogram Transformation 

• Selezionare nella tendina l’immagine stretchata  

• Cliccare sul cerchio blu in basso a sx. → si apre la preview  

• Spostare il cursore dei toni scuri sino all’inizio della curva → si scurisce lo sfondo 

• Applicare e resettare 

• Spostare il cursore dei medi sino a schiarire→ regolo sino a vedere un’immagine di preview soddisfacente non 
troppo bruciata nei toni chiari 

• Ogni volta applico e resetto 

• Chiudere sia processo e sia la sua finestra di preview. 

Creare copia di Backup che potrà servire per elaborare le stelle 
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22) CORREGGERE I BORDI 

Aprire il process Dynamic Crop → Serve per la rimozione degli errori dell’Autocrop realizzato in Fase 2 dal WBPP  

Il processo si trova nel menu Process > Geometry > Dynamic Crop 

• Segnare col mouse l’area dove l’immagine risulta migliore, scartando cioè i bordi che presentano difetti 
o Eventualmente col mouse, tramite i cursori è possibile spostare i singoli bordi dell’area creata  

• Applicare il ritaglio mediante il flag verde → il bordo dell’immagine viene ritagliato 

 

ELABORAZIONE COSMETICA DELL’IMMAGINE 

 

23) MASCHERATURA DELLE STELLE - Questa parte di lavorazione si chiama Star Mask 

Eseguire il Process Starnet2  

• Stride → si lascia 256 come indicato di default 
o Passare a 128 penalizzerebbe i tempi di esecuzione ed il risultato non sarebbe così molto diverso 

• Linear data → rimuovere la spunta, l’immagine è già stretchata. La si lascerebbe se l’immagine fosse lineare 

• Create Starmask → Spuntare la voce 

• Applichiamo il process portando il triangolo blu sull’immagine. 

Si avranno ora due finestre, una con la nebulosa e l’altra con le stelle. L’immagine delle stelle presenterà dei colori falsati 
dove prima c’era la nebulosa, ma questo si correggerà dopo. 

Cambiare il nome all’immagine con le stelle, chiamandola “STELLE” (tutto in maiuscolo perché così è richiamata in altra 
funzione) 

Ridurre ad icona l’immagine delle stelle: simbolo “-“ in alto a destra dell’ immagine. 

Nota: Arrivati qui non si deve più variare nulla tra le due immagini (es. il crop) altrimenti non si riesce più a 
rimetterle assieme 

 

In alternativa si dovrebbe prima creare la maschera di Luminanza per avere l’immagine in bianco e nero, poi aprire il process 
StarMask. Il Noise Threshold serve a far riconoscere a process quali sono le stelle: spostarsi col mouse sulle stelle più piccole 
che si vuole includere e leggere l’intensità K (si legge sulla barra di Pixinsight in basso). Andare a scrivere questo valore nel 
campo Noise Threshold. 

Scale è un valore che fa rientrare le stelle grandi che eventualmente son rimaste fuori, ma se si aumenta troppo il valore si 
rischia di fare entrare nella maschera anche le zone delle nebulose, i filamenti, ecc. Normalmente è corretto tra il 5 e il 6.  

Il process ricava i diametri delle stelle un po’ più grossi di cosa sono le stelle, ma serve per preservarne la luminosità. Questa 
maggior larghezza può essere regolata con i parametri Large-Scale per le stelle grandi e Small-Scale per le stelle piccole: 
diminuire questo valore se si vuole questi diametri siano più ridotti, e viceversa. Compensation serve anch’esso a ridurre il 
diametro delle stelle piccole ma il valore di 2 funziona quasi sempre bene. 

Smothness regola la sfocatura del contorno delle stelle, a volte è utile avere un valore minore di 16 

Binarize consente di avere le stelle tutte alla stessa intensità, se attivato occorre alzare moltissimo il Noise Threshold (es. da 
0,006 a 0,10) e lo Smothness dovrà essere ridoddo es. da 16 a 10. 

Contours consente di effettuare una riduzione dei diametri stellari per una visualizzazione più naturale: generare una 
maschera con contorni attivati genererà una maschera che contiene solo i contorni delle stelle. 

Abbassando il valore di MidTones da 0,5 a 0,05, aumenta la capacità del process di vedere le piccole stelle. Diminuendo 
ancora il valore a 0,025 ed aumentando un pochino la sensibilità Noise Threshold a 0,0060, la maschera ancora priva di 
rumore includerà ora una grande quantità di stelle. 

Eseguire ogni volta il processo trascinando il solito triangolo sull’immagine. 

 

LAVORAZIONE SULLA NEBULOSA 

 

24) CREARE MASCHERA DI LUMINANZA 

Estrarre la maschera di luminanza cliccare il pulsante “Extract CIE L* component” presente sulla barra in alto di Pixinsight. 
(attenzione a non usare il pulsante vicino che invece separa i canali RGB) 

o Viene creata una immagine in bianco e nero della luminanza della nebulosa: la usiamo come maschera 
affinché i processi dopo vengano applicati solo sulla nebulosa e non sul profondo cielo. 
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25) MODIFICARE L’ISTOGRAMMA DELL’IMMAGINE 

Serve per ottimizzare i colori della nebulosa 

Aprire il process Histogram Transformation. 

Si trova in Process > Intensity Transformation > Hystogram Transformation 

Dal menù a tendina scelgo l’immagine di luminanza: il nome del file con la L creato dall’Extract CIE L* Component” → in 
questo caso si chiama “B DBE L”  

• Ottenere la Real Time Preview → Clicco sul cerchietto blu in basso a sinistra 

• Scurire lo sfondo → sposto il cursore delle ombre (sotto la finestra del grafico) sino a metà dell’istogramma, in 
questo modo il fondo cielo risulta scuro di colore uniforme → deve essere nero 

• Applicare la modifica → applicare mediante pulsante quadrato in basso a sinistra, poi resettare col pulsante più a 
destra. Stiamo di fatto stretchando la nostra immagine → Resettare 

• Spostare eventualmente il cursore dei toni medi sino a schiarire la nebulosa, ed eventualmente anche quello delle 
luci sino a vedere un’immagine di preview soddisfacente sulla nebulosa, ma senza mai alterare lo scuro uniforme 
del profondo cielo. 

o In questo process devo resettare dopo ogni volta che applico una correzione. 

Applicate le migliori condizioni, chiudo sia processo e sia la sua finestra di Real-Time Preview.  

 

26) CREARE UNA IMMAGINE NERA da usare per eventualmente annerire aree su maschere 

Aprire il process Pixel Math e nel campo formula digitare “0”  

Destination → create new image 

Applicare cliccando il tasto quadrato in basso a sx →  verrà creata una immagine nera da usare con Clone Stamp 

 

27) ELIMINARE eventuali MACCHIE se presenti sulla parte di profondo cielo  

Aprire il process Clone Stamp → cliccare sull’immagine da modificare 

Si trova in Process > Painting > Clone Stamp 

• Radius → Definire un raggio adeguato alla macchia da eliminare, es. 100 

• Softness (morbidezza) → 1.00 

• Opacity (opacità) → 0.70 

• Attivare lo script → Tasto Ctrl + click su un punto nero di origine 
o L’origine può anche essere una immagine nera creata mediante il process Pixel Math 

• spostarsi col mouse sulla macchia → si forma un cerchio col quale si colora l’area da correggere 

• Applicare lo script → Tasto spunta verde, altrimenti la croce di colore rosso per eliminare l’azione poi Reset 

Nota: Eventualmente, tramite Histogram Transformation cercare di tagliare un poco gli scuri fermandosi prima del primo 
picco di scuri e poi regolare un poco i valori medi 

 

28) APPLICARE LA MASCHERA SULL’IMMAGINE 

Trascinare la label dell’immagine della Luminanza così aggiornata (a sinistra della finestra) sulla label dell’immagine della 
nebulosa → L’immagine diventa rossa dove viene mascherata, mentre rimane trasparente nelle zone dove avverranno le 
modifiche che faremo. La maschera applicata lavorerà anche sulle immagini di preview. 

Con la pressione dei tasti Ctrl-K posso nascondere o fare riapparire questo colore rosso.  

Mediante pulsanti c’è anche la possibilità di invertire la maschera, o di staccarla. 

L’immagine della Luminanza B_DBE_Spet_Strached_L è opportuno conservarla →Abbassiamo con tasto “-“ Iconize 

 

Per informazione, se elaboriamo un’immagine con stelle, vedere paragrafo 16. 

 

29) CREARE UNA RANGE MASK 

Il process Range Selection crea una maschera binarizzata che utilizza solo le parti chiare dell’immagine → La sua esecuzione, 
partendo dalla nostra immagine, crea una maschera in cui considera le parti chiare che diventano bianche e le parti scure 
che diventano nere; le parti sfumate non le considera. 

Aprire pertanto il process Range Selection  

Si trova in Process > Mask Generation > Range Selection 

Cliccando il cerchio blu viene mostrata l’area di intervento: “Real-Time: Preview Range Selection”.  

• Cursori Lower limit e l’Upper limit → Regolano l’area di intervento 
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o Si deve arrivare a coprire la nebulosa senza intaccarne le zone esterne → è meglio un poco più grande 

• Fuzziness → Permette di sfumare l’area di intervento  

• Smoothness Lavora sulla morbidezza di intervento 

• Col tasto quadrato applico il process e questo crea la maschera “range_mask”  
o Se questa “range_mask” creata presenta aree chiare non desiderate, prima di usarla occorre scurirla 

tramite il process Clone Stamp come spiegato al punto 25 

• Chiudere la Real-Time: Preview di Range Selection 

• Staccare la maschera di Luminanza “B_DBE_Spet_Strached_L” dalla nostra immagine 

• Applicare la maschera “range_mask” → Trascinare la sua label sulla barra laterale dell’immagine  
o L’immagine diventa rossa dove mascherata e la sua label diventa marrone 

• Abbassare ad icona la maschera “range_mask” 

 

30) DECONVOLUZIONE della Nebulosa  

Serve per migliorare la nitidezza, correggendo difetti dovuti al sistema ottico usato, al disturbo dell’atmosfera, alla sua 
turbolenza, ecc. Inoltre ridona dettagli alle zone molto luminose dell’immagine come ad esempio i nuclei delle nebulose. 

Aprire il process Deconvolution 294 → Su un’immagine con le stelle, di solito dobbiamo utilizzare l’External PSF mentre se 
non ci sono stelle, ma solo la nebulosa questa finestra non ci serve, è invece sufficiente la Parametric PSF. 

 

Parametri iniziali in Parametric PSF 

• StdDev → la porto inizialmente a 1.80 – Alzare il valore sino a che non si creino macchie, artefatti neri 

• Shape → 0.45 

• Aspect Ratio → 1.00 

• Algorithm →Regularized Richardson Lucy.  
o L’algoritmo Van Cittert è molto più aggressivo, si usa meglio su planetario. Su nebulose si usa con massimo 

20 Iterations  

• Iterazione → 90 se ne possono fare anche meno. L’iterazione agisce sulla luminanza del soggetto 
o Con Regularized Van Cittert impostare massimo 20 Iterations 

• Deringing → Tolgo la spunta 
o Il Deringing normalmente si usa quando si hanno anche le stelle. Serve ad evitare che le stelle risultino 

troppo ridotte, rimpicciolite a seguito della deconvoluzione. Agisce per evitare che si formino degli aloni 
neri, dei cerchietti, degli artefatti. Si usa il Deringing abbinato ad una Star Mask delle stelle in Local 
Support. 

o Se usato: Global Dark → 0.1100  -  Global Bright → 0.0800 

 

Parametri in Wavelet Regularization: 

• Wavelet Regularization → Lasciarla abilitata / spuntata 

• Parametri di soglia di rumore (Noise threshold) e Riduzione del rumore (Noise reduction) → Lasciare questi valori 
in modo che il primo abbia una maggior aggressività rispetto ai successivi a scendere, cioè siano in modo scalare sia 
come intensità, sia come quantità. 

Fare una Preview sull’immagine, comprendendo una parte della nebulosa ed un poco di profondo cielo → vantaggi: vedo i 
risultati su una parte di immagine ingrandita, eseguo prove sulla preview per valutare il contrasto giusto in modo molto più 
veloce. 

Con Undo: Deconvolution posso rimuovere il process applicato, mentre con Redo, posso rimettere le condizioni tolte. 

Ovviamente più si migliora la nitidezza e più si corre il rischio di aumentare anche il rumore. 

Riprovo sino a trovare i valori giusti che non creano artefatti →  se vedo puntini neri aumento i primi due valori di Noise 
Threshold del pannello Wavelet Regularization. I valori devono sempre stare scalati. 

Porto il triangolo blu sulla finestra della nebulosa per estendere l’applicazione. 

o Eventualmente sospendo la Deconvolution, applico un TGVDenoise Medio e poi ripeto la Deconvolution. 

 

31) SECONDA RIDUZIONE DEL RUMORE di crominanza su profondo cielo in lineare 

Tornare a vedere la maschera di Luminanza → Ctrl-K 

Invertire l’area di applicazione della stessa → Col tasto in alto delle icone di menu Pixinsight 

Applicare il process TGV Denoise denominato Basso → non quello più aggressivo  

Si trova nel menu Process → NoiseReduction → TGVDenoise 
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Parametri di processo: 

• Automatic Convergence → Spuntare la scelta 

• Iterations → 500 

• Local Support → Non attivo perché non vogliamo usare una sua specifica maschera. 

Applichiamo il process portando il triangolo blu sull’immagine. Lo script creerà le maschere e applicherà i processi in 
sequenza, prima TGV Denoise e poi il Multiscale MT. 

 

In alternativa, riduzione del rumore con Multiscale Linear Transform attivando per tutti i layer la voce Noise Reduction e 
impostando per ogni layer un Treshold un valore che si riduce passando dal primo all’ultimo layer: es. 1500 il primo; 1100 il 
secondo e poi 0,7; 0,3; 0,2 

 

Disapplicare la maschera → la disapplichiamo tramite l’icona con la X sulla barra dei menu di Pixinsight  

o la labella non è più marrone ma grigia, quindi la maschera non è più applicata,  
o la preview la conserviamo perché ci può ancora servire. 

 

32) AUMENTARE CONTRASTO ZONE SCURE  

Serve per migliorare le zone scure delle nebulose, accentuare le zone di gas 

Aprire lo script Dark Structure Enhance 

Si trova in Script > Utility > Dark Structure Enhance  

• Iterazioni →  Lasciare a 1 per non esagerare 

• Amount →  impostare ad un 20% (0,20) - Se voglio esaltare i neri posso anche aumentarlo, ma senza esagerare 
altrimenti diventano troppo profondi 

• Mask Parameters → come di default  

Lo script viene eseguito dando l’OK 

 

33) UN LEGGERO HDR sempre per accentuare le zone di gas 

Aprire lo script EZ HDR ed applicare lo script mediante Run EZ HDR → Termina con la nostra immagine miscelata, più la 
maschera dove ha lavorato e più l’immagine più dura HDR molto esagerata che ha usato (la possiamo vedere tramite icona 
del monitor su barra menu).  

• HDR Layers → 7 

• HDR Blend → 0.30 (0.25 – 0.30 sono valori standard) 

Eseguire lo script → Proseguire con la nostra immagine, chiudere le altre due 

 

34) MIGLIORARE CURVE DI COLORE DELLA NEBULOSA 

Aprire il process Curve Transformation → Applicare la Preview 

• RGB → creare una leggera curva ad S per aumentare il contrasto 

• Saturation → applico un minimo di saturazione 

• Applicare con il tasto quadrato, poi chiudere Process e Preview 

 

35) MIGLIORARE I CONTRASTI della nebulosa (con maschera di luminanza o con Range Mask applicata) 

Aprire il process Local Histogram Equalization → Agisce sull’istogramma nella zona che non è protetta dalla maschera 

Si trova in Process > Intensity Transformation > Local Histogram Equalization 

Cliccare sul cerchio blu in basso → si apre una preview in tempo reale dove possiamo vedere cosa cambia modificando i 
parametri 

• Kernel Radius → 60 - Un valore alto ammorbidisce l’immagine; un valore basso rende i contrasti più duri 

• Contrast Limit → Settare intorno 1.5-3.50 (massimo 3.5 – 4.0)  

• Amount →  È la percentuale applicata dal process → 200% (massimo 0.300 altrimenti oltre escono artefatti) 

Per migliorare parti bruciate aumentare il Contrast Limit e diminuire il Kernel Radius. 

Nebulose molto diffuse in cui non ci sono problemi di bruciature si può salire con il Kernel Radius. 

Nelle galassie e dove si vuole ottenere un contrasto più forte il Kernel Radius si abbassa intorno 50 che dà molta più 
aggressività. 

Applicare il process tramite il pulsante quadrato, chiudere process e preview. 
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36) SCURIRE eventualmente LO SFONDO del cielo 

Invertire l’area di applicazione della Range Mask 

Aprire nuovamente il process Curve Transformation ed aprire la sua preview 

• RGB → creare una leggera curva ad S per scurire il cielo 

• CIE *L component (Lighteness) → applico una curva a ridurre la luminosità del cielo 

• Applicare con il tasto quadrato 

• Chiudere Process e Preview 

• Staccare la Range Mask 

Staccare la maschera di Range Mask dall’immagine  → La disapplichiamo tramite l’icona con la X sulla barra dei menu di 
Pixinsight e la conserviamo, può servire in altre situazioni, per es. se voglio poi modificare alcuni parametri solo sulla 
nebulosa o solo sul fondo cielo. 

 

37) REGOLAZIONE DEI COLORI della nebulosa 

Con le diverse le maschere del colore: RedMask, CianoMask, ecc. creeremo le maschere di ciascun colore → Per ottenerle 
basta trascinare sull’immagine la Mask del colore scelto.  

Si crea ogni volta la maschera della zona interessata dal colore scelto → Su questa trascino sopra, anche più volte, il Mask 
Blur per ammorbidire l’area interessata, oppure apro il process Mask Blur modificando il valore “sigma” e poi lo applico. 

Quando la maschera ha raggiunto le condizioni che reputiamo migliori → Trascinare la Label della maschera sulla Label 
dell’immagine → tramite Ctrl+K è possibile nascondere o rivedere la maschera applicata. 

 

Con Histogram Transformation possiamo regolare l’istogramma, sia dell’immagine, sia delle maschere create. 

Apro la preview tramite tasto col cerchio blu e inizio a spostare i cursori eliminando le parti inutili dell’istogramma, facendo 
attenzione di non intaccarlo: nel campo “Shadows” leggo i pixel tagliati. Iniziando dai mezzi toni, poi i toni scuri e poi di 
nuovo i mezzi toni ed i toni chiari, applicando col tasto quadrato e resettando ogni volta. 

 

Con Clone Stamp possiamo andare a scurire le aree non di interesse, presenti sulle maschere 

 

38) CORREGGERE COLORI DELLA NEBULOSA    

Prima si esegue una correzione generale senza maschere applicate 

• Aprire il process Curve Transformation → Richiamare la Preview per regolare le curve di colore 
o Prima con RGB/K → un poco di curva per aumentare il contrasto (abbasso i toni scuri ed alzo i toni alti). 
o Poi con S → aumentare un poco la saturazione  

Nota: toccando le parti dell’immagine, sul grafico si vedono le linee corrispondenti alle posizioni sul grafico. Volendo si 
potrebbe quindi modificare le singole posizioni. 

 

Dopo si applicano le maschere e si correggono i colori → Si inizia generalmente con la maschera del colore ROSSO 
apportando le seguenti regolazioni:  

• sul colore R → Alzo la curva del colore per esaltarlo 

• Migliorare il contrasto usando il colore complementare → Per il Rosso usare il complementare Verde creando una 
curva ad S abbassandola a destra ed alzandola a sinistra.  

• sul “C” colore → per aumentarlo un poco 

• sulla “S” saturazione → anche questa aumentandola senza esagerare (in alternativa si potrebbe usare il process 
Color Saturation) 

Posso sempre vedere la differenza tra prima e dopo tramite il simbolo del cerchio blu sulla preview,  

Applicare → Quando sono soddisfatto la applico tramite tasto quadrato e come sempre dopo resetto. 

 

Applico la maschera del ciano (anche senza chiudere Curve Transformation, ma solo riavviando la preview): 

• con il “B” → scendo un pochettino, piccole variazioni senza esagerare (salire per esaltare i gialli ed i verdi, scendere 
per andare sui blu, sui viola, sugli azzurri) 

• con il colore blu → aumentando un poco per esaltarlo 

Applicare → resettare sempre ogni volta 

 

Questo metodo vale per tutte le maschere che si andranno di volta in volta ad applicare. 
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39) ALTERNATIVA: USARE LO SCRIPT SELECTIVE COLOR CORRECTION 

Con lo script Selective Color Correction (si trova in Script > Toolbox > SelectiveColorCorrection) è possibile regolare i colori 
creando maschere all’interno dello script tramite i parametri di impostazione, oppure è possibile importare ed usare le 
proprie maschere create le diverse le maschere del colore: RedMask, YellowMask, ecc. andando a regolare poi i parametri di 
impostazione all’interno dello script. Tramite “Show mask è possibile vedere la maschera creata/modificata dallo script.  

 

40) RIMUOVERE DOMINANZE DI COLORE 

Con il process SCNR è possibile rimuovere le eventuali dominanze: normalmente il verde, ma dalla tendina di scelta rapida si 
possono scegliere il blu o il rosso. 

 

41) AUMENTARE CONTRASTO ZONE SCURE 

Applicare lo script Dark Structure Enhance ripetendo eventualmente il process 33 → Serve per aumentare l’evidenza, il 
contrasto delle zone di nebulosità oscura 

Rimuovere la maschera → A questo punto la foto della parte nebulosa è terminata, ora lavoriamo sulle stelle. 

 

42) MIGLIORAMENTO AREA TROPPO CHIARA – BRUCIATA 

Partendo dalla maschera di luminanza in banda stretta B_L, con Histogram Transformation vado a scurire sino ad ottenere 
visibile solo l’area più bruciata, poi con Range_Selection creo la Range_Mask dell’area. 

Applico la Range Mask sia alla mia immagine B e poi all’immagine RGB, con Curve_Transformation vado ad abbassare in RGB 
le parti più chiare cercando di non arrivare al grigiastro. Magari dando anche un poco di colore C. 

 

LAVORAZIONE SULLE STELLE 

 

43) ELIMINARE GLI ALONI   Non si esegue più 

Abilitare STF → per vedere correttamente l’immagine e l’alone bluastro nella zona dove c’era la nebulosa 

Usare la Range Mask fatta prima sulla nebulosa → aprirla e trascinarla sull’immagine STELLE  

Aprire il process Curve Transformation → lavorare con la preview per eliminare un poco il blu ed il verde. 

Applicare le modifiche ogni volta con tasto quadrato e come sempre dopo resetto. 

 

44) MIGLIORARE COLORE DELLE STELLE 

Riprendere la copia di Backup fatta al punto 22 

Estrarre la sua Luminanza → Serve per creare maschera delle stelle 

Applicare la maschera di Luminanza sull’immagine → Serve a proteggere lo sfondo 

Aprire il process Curve Transformation ed avviare la preview 

• Intervenire sul colore “C” → aumentarlo in modo deciso 

• Intervenire sulla saturazione “S” → migliorare il colore delle stelle  

• Con RGB/K → regolare la luminosità e contrasto delle stelle 

Applicare → tasto quadrato e Resettare 

Controllare il risultato ed eventualmente applicare ancora per intensificare l’effetto 

Chiudere il process e la sua preview 

 

45) SCURIRE IL FONDO CIELO 

Invertire la maschera → Serve per proteggere le stelle 

Aprire il process Curve Transformation → lavorare con la preview 

• Abbassare la curva RGB → scurire un pochettino il fondo cielo 

• Abbassare la luminanza “L” → abbasso per far scurire le parti bruciate della nebulosa che permangono 

Applicare → tasto quadrato e Resettare 

Applicare e resettare sempre e nel caso rifare ancora, poi togliere la maschera ma conservarla ancora 

Rinominare il file in STELLE 

Nota: Eventualmente, per ridurre l’intensità luminosa della galassia che a volte rimane, con la range mask della galassia 
applicata a proteggere lo sfondo, apro Histogram Transformation e tramite RGB/K riduco i toni medi 
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Nota Eventualmente, per migliorare la forma delle stelle e ridurre un poco i diametri stellari, con la maschera di luminanza 
delle STELLE applicata, applicare un po’ di Deconvolution prima di riunire le stelle 

 

46) ALTERNATIVA DI LAVORAZIONE SULLE STELLE avendo immagine salvata con nebulosa e stelle 

Creo luminanza e la applico 

Inverto luminanza applicata 

Curve transformation → RGB scurisco il fondo cielo 

Star Mask con luminanza applicata → creao la star mask e la applico 

Curve transformation → RGB: leggera S per migliorare colore 

➔ “C” per migliorare colore stelle 

Control K inverto maschera e proteggo le stelle 

Curve transformation  → RGB scendo per ridurre scurire lo sfondo 

 

47) RIUNIRE NEBULOSA E STELLE 

Avviare STARLESS CON STELLE → una formula in Pixel Math con Expression Editor scriviamo Nome immagine + STELLE.  

o L’espressione crea le mediane delle due immagini e le somma in modo che le stelle non vengano sovra 
saturate. 

Spuntare la voce Create new image e su Image Id segniamo il nome che vogliamo, es. NGC281 Pacman  

Avviare il process → Trascinare col triangolino il process sull’immagine della Nebulosa. 

 

48) LEGGERA RIDUZIONE DELLE STELLE 

Aprire lo script EZ Star Reduction → bisogna fargli creare una maschera sulle stelle -> Create Star Mask for Reduction 

Qualora non la crea, in Raw StarNet Star Mask indichiamo la maschera da usare → In Raw StarNet Star Mask -> indicare il 
file STELLE_L 

Star Reduction iterations → Ridurre il valore se ha ridotto troppo le stelle 

Dare il Run → lo script fa la riduzione delle stelle che così diventano molto più piccole. 

 

Nota: Certamente ancora meglio è fare esposizioni diverse in fase di ripresa: usando un tempo molto più breve per le stelle 
che così vengono meno sature, e non perdono il colore, rispetto un tempo più lungo per fotografare le nebulose. La troppa 
saturazione delle stelle comporta che esse perdono il colore e diventano bianche. 

 

49) SCURIRE ANCORA IL FONDO CIELO 

Avviare il process ArcsinhStretch_fondo cielo, → agisce solo sul fondo cielo e non sul soggetto. 

Si trova in Process > Intensity Transformations > ArcsinhStretch 

Aprire la preview in tempo reale 

• Flaggare le due voci Protect highlights e Use RGB working space 

• Volendo si può flaggare anche l’Highlight values clipped to zero che evidenzia i valori modificati 

• Cliccare l’Estimate Black Point → Il process fa una regolazione automatica dei neri: se sembra troppo si può 
modificare mediante cursore.  

• Attenzione: Se si rende troppo nero si perdono particolari dei gas intorno alla nebulosa. 

Applicare il process e resettare 

 

50) ULTIMA EVENTUALE RIDUZIONE DEL RUMORE 

Qualora si volesse ancora levare del rumore → TGV Denoise Basso 

• Fare sempre una Preview per vedere l’effetto degli interventi 

Chiudere sia la preview, sia il process e l’immagine è finita. 
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51) ROTAZIONE DELL’IMMAGINE 

Avviare il process Fast Rotation. 

Si trova in Process > Geometry > Fast Rotation 

• Indicare la rotazione voluta 

Applicare tramite il pulsante blu quadrato in basso a sinistra. 

 

52) COPYRIGHT 

Aprire process FITSHeader → per vedere i dati che la camera astronomia ha scritto nel file e inserire il Copyright 

Si trova in Process > Image > FITSHeader     

Name → Indicare il proprio nome o eventuale Nickname 

Value → Indicare “T” (True) 

Comment → Indicare “ALL RIGHT RESERVED” 

Alternativa: SCRIPT> RENDER> DRAW SIGNATURE per scrivere testo sull’immagine 

 

53) IDENTIFICARE STELLE E NEBULOSE con annotazione sull’immagine  

Aprire lo script Annotate Image 

Si trova in Script > Render > Annotate Image 

• Layers → Aggiungere col simbolo “+” oppure togliere col simbolo “X” i cataloghi di interesse in funzione delle 
annotazioni volute (Gaia ha troppe stelle, riempie tutto lo schermo di scritte, aggiungere NGC-IC, LDN, LBN, ecc.) 

• Show Markers → Regolare il colore voluto per i marcatori 

• Show Layers → Regolare il colore voluto per le annotazioni 

• General Properties → rimuovere flag d Apply STF before annotetion (l’immagine è già stretchata) 

• Observation → Indicare la data di ripresa dell’immagine 
o in caso di immagine derivata da raggruppamento di immagini aventi diversa data di ripresa → indicare 

almeno una delle loro date 

Dare esecuzione allo script mediante tasto “OK” → Verrà creata l’immagine annotata 

Qualora lo script non lavori, esempio per immagine croppata, eseguire lo script Image Solver come da Fase 11” 

 

54) SALVARE IMMAGINE  

Con FILE → Save As è possibile salvare l’immagine nei formati:  

- XISF se vogliamo utilizzarla in successive lavorazioni, (si possono fare le versioni con i canali scollegati, quindi la 
versione in HO o Hubble Palette con i processi di normalizzazione, usando le maschere di colore, ecc.)  

- TIFF a 16 bit (Pixinsight di default lo salva a 32 bit ma non va bene) per eventuale successiva elaborazione in 
Photoshop  

- Jpeg per tutti gli altri usi. 

 

 

  



Elaborazione astrofotografia deep sky  Ver. 04 del 14/10/2024 

A u t o r e  M a r i o  P a p o t t i  s u  s p i e g a z i o n i  d i  A l b e r t o  A i r o l a  P a g .  20 | 23 

 

NOTE SU PIXINSIGHT 

Gli script esterni che si vuole aggiungere, prima si 
salvano nella cartella Programmi – Pixinsight – nella 
cartella SRC poi, aperto Pixinsight si entra in Script – 
Feature Scripts e tramite tasto Add si individua il 
percorso dove sono stati messi e si seleziona la loro 
cartella. Scelto “Seleziona cartella”, si pressa il tasto 
Done e la finestra si chiude, Pixinsight li elabora e 
da quel momento sono disponibili. 

 

I Process esterni si aggiungono andando a copiare nella cartella “Bin” di Pixinsight i file costituenti il nuovo processo.  

Entrare quindi in Pixinsight e dalla label Process scegliere la voce “Modules” → “Install Modules” 

Cliccare “Search”, verrà individuato il modulo da installare, sceglierlo e cliccare “Install”. 

Da questo momento, aprendo nuovamente Pixinsight, essi risultano disponibili. 

 

Libreria GAIA  

Scaricare i file da Pixinsight: https://pixinsight.com/downloads/index.html   

• Disporre i files in specifiche directory es. “Gaia DR3 SP complet set” 

• Avviare Pixinsight ed aprire il process Gaia 
o Si trova in Process →  <All Process> → Gaia 

• Cliccare sull’icona della chiave inglese → dal menù a tendina scegliere la versione Gaia che si vuole installare 

• Premere il tasto “Select” → indicare il percorso dove sono archiviati i relativi file → Selezionarli tutti 

• Dare OK per salvare il percorso indicato 

 

Libreria APASS 

Scaricare i file da Pixinsight: https://pixinsight.com/downloads/index.html   

• Disporre i files in specifiche directory es. “Apas” 

• Avviare Pixinsight ed aprire il process APASS 
o Si trova in Process →  <All Process> → APASS 

• Cliccare sull’icona della chiave inglese → dal menù a tendina scegliere la versione Gaia che si vuole installare 

• Premere il tasto “Select” → indicare il percorso dove sono archiviati i relativi file → Selezionarli tutti 

• Dare OK per salvare il percorso indicato 

 

Label laterali Pixinsight 

Le label laterali sono: 

- Process Control (apre process già utilizzati) –  
- View Explorer –  
- Process Explorer –  
- Format Explorer 
- History Explorer –  
- File Explorer 

 

ELABORAZIONE DI MOSAICI  

I due o tre pannelli di foto vanno tutti calibrati allo stesso modo, per cui lo stesso process aperto lo si applica trascinandone 
il triangolino, successivamente su ciascuna immagine. 

L’elaborazione avviene su immagini calibrate 

• Eseguire il Plate Solver su ciascuna immagine e salvare 

• Aprire Mosaic by Coordinates → add file delle 4 o più immagini → Avvio 

• Aprire Gradient Merge Mosaic → add file per aggiungere le versioni allineate “Registered” delle immagini 

• Fare STF concatenata su new immagine 

• Con Dinamic Crop ritagliare i bordi 

• Salvare 

• Elaborare i colori 
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Creare Processo Pixel_Math 

Per creare un processo in Pixel_Math bisogna aprirlo ed inserire opportune formule nelle diverse Label. 

Per creare ad esempio HT_Stretch_Linked_RGB, bisogna aprire Pixel_Math e cliccare “Expression Editor” 

 

Si apre una finestra dove andare ad 
inserire le formule: nella label "RGB/K" 
fare copia/incolla del seguente testo così 
come scritto qui di seguito: 

 

 

 

 

 

 

 

/*      Linked Stretch in Pixelmath - V1   by Bill Blanshan                          

                     

Drag the bottom left arrow over into the image you want 
stretched */ 

 

C = -2.8  ;  //Shadow Clipping (Defualt value -2.8) 

B = 0.20  ;  //Background value (Higher the value, more 
stretched) 

//Equations by Juan Conejero  (Thanks Juan!!!) 

m = (med($T[0])+med($T[1])+med($T[2]))/3; 

d = (mdev($T[0])+mdev($T[1])+mdev($T[2]))/3;  

c = min( max(0,m+C*1.4826*d),1);  

 

mtf(mtf(B,m-c),max(0,($T-c)/~c)) 

 

 

Nella Label "Symbols" fare copia/incolla del seguente testo 
così come scritto quì: 

C,B,c,m,d,  

 

Dare OK 

La finestra si chiude e la formula è pronta. 

 

 

 

 

 

Per salvarla, trascinare il triangolo blu sulla lavagna di Pixinsight e 
dare il nome alla funzione cliccando su N (Nome) 

 

Salvando il Project l’icona resta disponibile 
per gli usi futuri 

 

Esportare Processo Pixel_Math 

Per esportare un processo bisogna averne l’icona sulla lavagna di Pixinsight. La si seleziona e col tasto dx del mouse si sceglie 
“Save selected icons”. Scegliere il percorso dove salvare → Salva 
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COME CREARE DELLE MASCHERE LOCALI CON PIXINSIGHT   https://www.youtube.com/watch?v=z3OBjQ3iUHw 

 

Creare maschera di luminanza delle stelle 

Con Histogram Transformation scurire il fondo cielo della luminanza → non preoccuparsi di perdere dettagli, importante è 
che devono rimanere le stelle, il soggetto, mentre il fondo cielo deve diventare uniformemente nero, altrimenti la star mask 
non risponderà bene. 

Duplicare la maschera di luminanza 

Aprire il process Star Mask → fare “reset” per rendere tutti i parametri di default 

Ingrandire l’immagine clonata di luminanza → Puntare sulle stelle più piccole, più deboli e vedere il loro valore K 

• Noise threshold → Indicare il valore letto → Questo dice a Star Mask che valori sotto quel valore sono rumore 

• Scale → lasciare 5 

• Large Scale → abbassare a 1 

Applicare con triangolo blu sull’immagine 

 

Applicare la Star Mask ottenuta all’immagine di luminanza e invertire la maschera per notare eventuali stelle rimaste 
bianche → queste non sono state coperte dal segnale → Eliminare in questo caso la Range Mask e rifarla 

• Noise threshold → alzare un pochino il valore 

• Scale → Se stelle luminose restano scoperte alzare il valore, es. portare a 7  

Riapplicare il process 

 

Applicare la Star Mask ottenuta all’immagine di luminanza e invertire la maschera per notare che tutte le stelle siano rosse, 
ovvero siano state comprese anche le stelle nella galassia → Se ok, rimuovere e conservare la Star Mask dall’immagine di 
luminanza creata 

 

Creare una immagine bianca / nera 

Aprire Pixel Math → Resettare 

• RGB/K → 1 (scrivendo 0 l’immagine verrebbe nera) 

• Destination → Create new image 

• Image ID → “Bianco” 

Applicare con quadratino Blu → si forma una immagine completamente bianca 

 

Aprire lo script Game 

Si trova in Script > Utilities > Game 

Si apre una finestra da cui è possibile scegliere: 

• se partire da una Ellipses → si forma una ellisse che poi posso modificare 

• creando dei Multi point → scegliendo manualmente dei punti a creare una forma che poi posso modificare 
o Ellipses → Cliccare su +add per creare nella preview una prima forma di ellisse  
o Multi point → Cliccare su +add per poter creare nella preview il primo punto da trascinare per creare 

l’area voluta. Partendo dal punto rosso si aggiungono tanti punti a piacere trascinabili per poter formare 
l’area voluta 

o Trascinare i punti azzurri per dare la dimensione voluta 
o Trascinare il punto rosso per spostare la forma sull’area voluta 
o Si possono creare anche più forme sulla stessa preview 
o Write shapes to Files/Views → Applicare le forme dal contorno netto all’immagine che scelgo 
o Export Masks → scelgo il tipo di maschera voluta 
o Dando l’OK → Crea la maschera da applicare  
o Con il process Convolution posso ancora ammorbidire la maschera creata, come fosse un MaskBlur 

 

Serve in particolare per eliminare errori di crominanza del profondo cielo 

Applicare la maschera sull’immagine → per proteggere il soggetto 

Applicare una leggerissima Convoluzione → tutti i punti colorati vengono sfumati e la situazione migliora 

 

 

https://www.youtube.com/watch?v=z3OBjQ3iUHw
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CREARE FILTRI PERSONALIZZATI per SPCC 

Filter Manager 

Cliccare curve Explorer 

Scegliere primo filtro, es Sony Color Sensor R 

Pressare tastro CRL e contemporaneamente scegliere secondo filtro es Optolong L-Pro 

Cliccare icona Combine → si trova in basso a sx, costituita da quadratini colorati  

Dare nome al nuovo insieme filtro 

Assegnare un Filter channel: G / B / R 

Dare OK ed ancora OK 

Confermare di Salvare 

Ora restano disponibili il SPCC 

 

Esportare Filtri 

CSV 

Creare cartella CSV_Filtrers 

Esportare file nella cartella specificata → verranno creati file per ciascun filtro presente 

I file sono leggibili con Excel 

XML 

Esportare file nella cartella specificata → verrà creato un file XSPD con i dati di tutti i filtri presenti in Pixinsight 

I file sono leggibili con il programma “Sublime Text” 

 

 

 

Spiegazione difetti estetici 

In questa immagine si vedono bene 2 tipici 
difetti: la vignettatura e il gradiente (ce ne 
sono altri ma lasciamo perdere :D ). 

La vignettatura si nota bene come calo di 
luminosità ai bordi e si può correggere bene 
con il flat. Direi che si tratta di un difetto di 
luminosità, essa cala man mano che ci si 
avvicina ai bordi del fotogramma. 

Il gradiente: come puoi vedere la parte destra 
del fotogramma tende al verde e quella 
sinistra al magenta. In questo caso è più un 
problema di crominanza, non è una variazione 
di luminosità bensì una differenza di tonalità 
colore del fotogramma. Questo non si elimina 
con il flat. In questa foto i due difetti si 
sommano (vignettatura e gradiente). Questi 
difetti vengono evidenziati dai processi 
elaborativi (stretching e simili), nel singolo 
fotogramma sono poco evidenti. 

 

Per l’inquinamento luminoso che lascia gradienti e rumore sul fondo cielo si può provare ad intervenire tramite Histogram 
Transformation e taglia un po' di più gli scuri aiutandosi con la live preview. 

 


